Resolved
We have resolved the outage - a bug in the rotation logic for our worker client certificates caused the cluster to reach an unhealthy state.
Monitoring
Fix deployed
Investigating
We are investigating an issue affecting access to the Dashboard. MCP Servers may also be affected. We are working to restore service.
Investigating
We are investigating an issue affecting access to the Dashboard. We are working to restore service. MCP Servers remain operational and are not affected.